summaryrefslogtreecommitdiff
path: root/test/files/run/collection-conversions.scala
Commit message (Collapse)AuthorAgeFilesLines
* Cull extraneous whitespace.Paul Phillips2013-09-181-4/+4
| | | | | | | | | | | | | | | | | | | | | One last flurry with the broom before I leave you slobs to code in your own filth. Eliminated all the trailing whitespace I could manage, with special prejudice reserved for the test cases which depended on the preservation of trailing whitespace. Was reminded I cannot figure out how to eliminate the trailing space on the "scala> " prompt in repl transcripts. At least reduced the number of such empty prompts by trimming transcript code on the way in. Routed ConsoleReporter's "printMessage" through a trailing whitespace stripping method which might help futureproof against the future of whitespace diseases. Deleted the up-to-40 lines of trailing whitespace found in various library files. It seems like only yesterday we performed whitespace surgery on the whole repo. Clearly it doesn't stick very well. I suggest it would work better to enforce a few requirements on the way in.
* Renaming convertTo to to on GenTraversableOnce.Josh Suereth2012-06-281-8/+8
|
* Parallelize convertTo in parallel collection.Aleksandar Prokopec2012-06-271-1/+5
|
* Migrate build to @odersky's suggestion of convertTo.Josh Suereth2012-06-181-7/+7
| | | | | | * Move method into TraversableOnce from Iterator and Traversable to make the build pass. * Udpate IDE tests with new collection methods. * Rewire default toXYZ methods to use convertTo.
* Rename copyTo to build based on consensus of 3Josh Suereth2012-06-181-7/+7
|
* Fixes from review.Josh Suereth2012-06-181-7/+7
| | | | | | * Fixed typo * Renamed copyInto to copyTo * Added tparam doc.
* Adding copyInto and toVector methods to collections.Josh Suereth2012-06-181-0/+60
* Added generic copyInto method for collections. For any collection with a CanBuildFrom, can convert a generic collection into it using the builder. * Added specifici toVector method for collections. This is more efficient than copyInto if the collection is a Vector.